Hogyan lehet kikapcsolni az F1 és az F10 billentyűkombinációt a gnome-terminálon?

115

Hogyan kapcsolhatom le a F1 (súgó) és a F10 (értesítések menü) kulcslekötéseket?

Először is szükségem van a képernyő-segédprogramra, a második pedig kilép amc -ból a konzolban.

A Billentyűparancsok rendszerbeállítások nem tartalmaznak ilyen kulcskötéseket.

    
készlet Marko Kevac 27.04.2011 15:55
forrás

14 válasz

107

11.04

Az F1 parancsikon letiltása

  1. Egy gnome-terminálon nyissa meg a Edit ➜ billentyűparancsokat .

  2. Görgessen lefelé a Súgó / Tartalom parancsikonra, kattintson arra az oldalra, ahol az "F1" és nyomja meg a Backspace

Az F10 gyorsbillentyűjének letiltása

  1. Telepítse a compizconfig-settings-manager csomagot.

  2. Nyisd meg a CompizConfig Beállítások menedzsert .

    • Hit Super megnyitni a Dash parancsot, írja be a "Compiz" parancsot, és nyomja meg a Enter billentyűt.
  3. Írja be az "unity" -t a Filter bejegyzésbe, és válassza ki az Ubuntu Unity Plugin elemet.

  4. Kattintson az Kulcs megnyitásához az első panel menü megnyitásához, és törölje a jelölőnégyzetből az Engedélyezett jelölőnégyzetet.

  5. A globális F10 parancsikon letiltása, most tiltsa le a gnome-terminal F10 parancsikonját:

    • A gnome-terminálban nyissa meg a billentyűparancsokat ( Szerkesztés ➜ Billentyűparancsok) és [ törölje a Engedélyezze a menü gyorsbillentyűt (F10 alapértelmezés szerint)

  6. Az F10 a menubar_accel-re van feltüntetve valami Ubuntuban. Gnome? Metacity? Nem biztos benne, hogy pontosan mi az, ami ellopja, de a kulcs nem teszi az Eclipse-t.

    • Futtassa a gconf-editorot, keresse meg a / desktop / gnome / interface, majd görgessen le a menubar_accel fájlra és törölje az F10 értéket. [Lopott innen]
válasz adott Isaiah 23.06.2011 20:52
forrás
44

Letiltja az F10-et gnome-terminálon 12.04-ben

Írja be ezt a konzolban:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Ezután zárja be az összes terminál munkamenetét. Most úgy kell működnie, ahogy kellene (példáulmc).

válasz adott Paweł Gościcki 30.04.2012 21:25
forrás
23

indítsa el agconf-editor -ot és kövesse/apps/gnome-terminal/keybindings/help

Leírás:

"A billentyűzet gyorsbillentyűje a súgó elindításához, amelyet a GTK + erőforrásfájlokhoz hasonló formátumú karakterláncként fejez ki Ha az opciót a" letiltott "speciális karakterláncra állítja be, akkor erre a műveletre nem lesz gyorsbillentyű."

    
válasz adott Rinzwind 21.08.2011 22:28
forrás
7

Új vagyok a Linux-ra, és ez az F10 kulcs meghajt engem. Az összes fenti trükkök nem működtek, de találtam megoldást (az Ubuntu 11.10 és a Gnome 3 klasszikus asztal esetében). Egy terminálon írja be a következő parancsot:

gsettings set org.gnome.desktop.interface menubar-accel ""

A dconf-editor segítségével megállapítható, hogy az F10 tényleg elment. Megjegyezzük, hogy ezek a trükkök nagy mértékben függenek a Gnome / Ubuntu változattól.

    
válasz adott gast128 29.11.2011 20:34
forrás
4

Kilépés a mc-ből (F10 billentyűvel). Letiltja a "Kulcs megnyitásához az első panel menüt" az unity compiz pluginben (ccsm)

    
válasz adott kholis 29.04.2011 12:33
forrás
4

A @kholis helyes az F10-nek az Unity-ban való letiltásával, de ha te vagy új, mint én, akkor még egy kicsit több információra van szüksége ahhoz, hogy ezt a munkát elvégezd.

Ha még nincs telepítve, telepítse a compizconfig-settings-manageret:

sudo apt-get install compizconfig-settings-manager

Indítsa el az újonnan telepített beállításkezelőt, és szűrje az "egység" kifejezést

A "Kulcs megnyitásához az első panel menüjének" szerkesztéséhez tiltsa le, vagy módosítsa egy másik kulcsra.

Még nem találtam módot az F1 módosítására.

válasz adott Ryan Sorensen 30.04.2011 19:36
forrás
3

A hivatkozás (az alábbiakban idézett) utasítás az Ubuntu 11.04-ben is működik. (Úgy tűnik, hogy letiltja az F1-et mind az asztalon, mind a terminálban, vagyis az F1 nem küld ansi szekvenciát a terminál shelljébe, ha az OP ezt akarta.)

  
  1. Ugrás a Rendszer - Beállítások - Billentyűparancsok
  2. lehetőségre   
  3. Hozzon létre egy új parancsikont. Nevezd meg, hogy "ne csinálj semmit", és írj "hamis"   (idézőjelek nélkül) a "parancs" mezőben. Nyomja meg rendben.
  4.   
  5. Görgessen a lista aljára, és keresse meg az új parancsot. Kattints   a "Letiltva", a jobb oldalon, és nyomja meg az F1 billentyűt.
  6.   
    
válasz adott David Andersson 22.08.2011 04:12
forrás
3

Akkor könnyedén letilthatja a CCSM használatával (kattintson ide a telepítéshez, ha nincs telepítve ).

Ezután menjen az Asztalra - > Ubuntu Unity Plugin - > Az első panel menüjének megnyitásának kulcsa, és tiltsa le vagy más billentyűparancsra.

Megjegyzés : úgy tűnik, hogy ez a módszer nem működik a Unity2D-ben.

    
válasz adott Binarylife 27.10.2011 00:03
forrás
2

Ez a csúcs Thnkpad felhasználóknak, különösen a T60-nak. Az F1 kulcsot távolítsa el a meneküléshez. Ez kiküszöböli a terminális segítség bosszantó felbukkanását, amikor az F1-et eltalálja. Gyakran csinálod ezt az ESC vicces elhelyezését a T60-asokon.

    
válasz adott ncmathsadist 03.12.2011 18:42
forrás
1

Ha csak a Gnome Terminal -et szeretné módosítani, akkor a Terminálon kattintson a Szerkesztés > billentyűparancsok lehetőségre.

    
válasz adott Jeremy Bicha 30.04.2011 20:37
forrás
1

Azt javaslom, hogy az F1 parancsot valami mást használj. Futtatom a Tildát, a rengés-stílusú parancssori terminált, és az alapértelmezett parancsikon az F1. Ez felülbírálja a Súgót, így soha nem tudok Súgót indítani, amikor eltalálom az F1-et. Még ha nem is tetszik Tilda, az F1-re ismét elrejteni, sokkal kevésbé unalmas, mint a Súgó bezárása a véletlen elindítás után.

    
válasz adott titaniumtux 03.12.2011 20:23
forrás
1

12.04

F1 úgy tűnik, nem csinál semmit a dobozból 12.04-kor, a F10 Tehát válaszul a kérdés sajátosságaira, nincs szükség a segítség és az értesítések letiltására.

Még mindig megteheti őket valami másra:
A hot-keys 12.04-ben történő leképezése egyszerűen a billentyűzet widgeten keresztül valósul meg.

Az Unity indítóban megtalálja a billentyűzetet.

A megnyíló ablakban jelölje ki a gyorsbillentyűket és az egyéni parancsikonokat Kattintson a plusz elemre egy új parancsikon hozzáadásához.

Adja meg, hogy bármi is egyezik azzal a funkcióval, amelyet hozzárendel Adja meg azt a parancsot, amelynek parancsfájlját futtatni szeretné.

Az ablak jobb oldalán kattintson a letiltott helyre. Ez váltson új gyorsítóra.

Most nyomja meg a F10 Az Ön által definiált egyéni gyorsbillentyűk felülbírálják a jobb egérgombbal kapcsolatos szimulációs viselkedést. Ezt a parancsot beállíthatja aecho 'nope' > /dev/null -ra, ha csak azt szeretné, hogy az F10 ne csináljon semmit.

    
válasz adott RobotHumans 02.04.2012 19:50
forrás
1

12.04 Egység nélkül - Az F1 és F11 viselkedés tiltása

Telepítettem az Ubuntu 12.04 / 64-es verzióját, és teljesen eltávolítottam az Unity-t a ezeket az utasításokat követve . Sok olyan eszköz, amely módosítja az Unity viselkedését, ezért nem működik. A CCSM már nem látja a billentyűparancsokat.

Megállapítottam, hogy a terminál ablakában a Szerkesztés > billentyűparancsok módszer sem működik. Miután egy kicsit játszottam, azt találtam, hogy a Gyorsbillentyűk szakaszban a Billentyűparancsok ablakban az F1 és az F11 még mindig a megfelelő hivatkozásokra van definiálva.

A probléma megoldásához

  1. Kattints az "F11" -ra a definiált vonal jobb oldalán F11 teljes képernyőn. A szöveg "Új gyorsító" -ra változik.

  2. Írjon be egy másik, kevésbé kifogásolható kulcsszekvenciát (például alt-F11) és hogy a billentyűparancs kicseréli a parancsikont. Ha valaki tudja, hogyan írja be a "semmit", kérjük, tudassa velünk.

  3. Ismételje meg az F1 billentyűt.

válasz adott Wes Miller 20.11.2013 17:33
forrás
0

A Ctrl + F1 nem működik sem. A megoldás ugyanaz, mint a Shift + F10 esetében. Ne felejtsük el a pontosvesszőt szeparátorként!

Tegye ezt a ~ / .config / gtk-3.0 / gtk.css fájlba:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
válasz adott egmont 16.03.2014 12:46
forrás