Csatlakoztassa / szétkapcsolja a VPN-t a parancssorból

111

Van két VPN-beállításom az Ubuntu gépemen, az egyik a vpnc és a PPTP használatával. Ezek mind a GNOME hálózati kezelőfelületen történtek, és remekül működnek. Időnként azonban távolról is hozzáférnem kell ehhez a géphez - van-e mód arra, hogy a VPN-ekhez kapcsolódjon vagy kapcsolódjon le a parancssorból?

    
készlet Tim Fountain 16.08.2011 17:15
forrás

2 válasz

163

Ha a parancssorból szeretne kommunikálni a NetworkManagerrel, használhatja az "nmcli" parancsot.

felsorolja az összes NM kapcsolatot:nmcli con

kapcsolat indítása (wifi, vpn stb.):nmcli con up id ConnectionName

down kapcsolat:nmcli con down id ConnectionName

(több nmcli parancs a nmcli manpage-ban ).

Vegye figyelembe, hogy a rendszeres felhasználóknak általában nincs engedélyük a hálózatkezelés ellenőrzésére. A fenti parancsok használata asudo -nál a legtöbb kapcsolatnál működik, de a VPN kifejezetten sikertelen lehet "Hiba: A kapcsolataktiválás sikertelen: nincs érvényes VPN titka."

Ha ez megtörténik veled, valószínű, hogy a VPN-jelszó a felhasználó gnome-kulcstartójába kerül, ami hozzáférést nem enged a root felhasználónak. Ez a megjegyzés megmagyarázza, miért.

A / etc / NetworkManager / system-connections / ConnectionName és[vpn] alatt módosítsa a jelszó zászlók sor:

password-flags=0

Ha van egy sor, amelyXauth password-flags -al kezdõdik, inkább helyettesítsd.

Ezután adja hozzá a[vpn] blokkot:

[vpn-secrets]
password=YourPassword

(Ha az előző lépésben megváltoztatta aXauth password-flags sort, akkor helyezze el aXauth password=... értéket.)

Most indítsa újra a hálózati menedzsert:

sudo service network-manager restart

Akkor pedig asudo nmcli con up id ConnectionName -al rendelkező VPN-kapcsolatot el kell indítanunk.

    
válasz adott ihashacks 17.08.2011 05:44
forrás
4

ihashacks válasza Matt észrevételeivel dolgozott nekem ... szinte. Egy sort kellett csípnie.

a jelszó-zászló sorom ténylegesen elolvasta: "Xauth password-flag". Az elfogadott válasz nem működne számomra, amíg nem változtam az alábbiakra

[vpn]
...
Xauth password-flag=0
IPSec secret-flags=0

[vpn-secrets]
Xauth password=<my pw> ## This is the one I changed.
IPSec secret=<group pw>

Nem biztos benne, hogy miért van vpn-kapcsolatom "Xauth" a jelszó minden megemlítése előtt.

(Sajnálom, ez egy új válasz, még nem tehet megjegyzést.)

    
válasz adott John 23.03.2015 06:03
forrás