Hogyan telepíthetem a Visual Studio kódot?

142

Most letöltöttem aVSCode-linux-x64 -ot a Microsoft webhelyéről . Ez egy 62 MB-os zip fájl. Hogyan telepíthetem az Ubuntu rendszeremen?

    
készlet Rasool 29.04.2015 23:00
forrás

13 válasz

127

Frissítés

A VSCode most elérhető DEB fájlként . Letöltheti és futtathatja:

sudo dpkg -i ~/path/to/code_1.XXX.deb

Ha adpkg a hiányzó függőségekről panaszkodik, futtassa:

sudo apt -f install

utána a probléma megoldásához.

Régi válasz

  1. A Visual Studio kódjának letöltése Linuxra
  2. Kibontás:unzip VSCode-linux-x64.zip -d ~/path/to/VSCode
  3. Indítsa el acode végrehajtható fájlt a Visual Studio kód
  4. megnyitásához
  5. (Opcionális) Hozzon létre egy szimbolikus linket acode eléréséhez a terminálról:
    sudo ln -s /path/to/VSCode/code /usr/local/bin/code

Forrás (telepítési utasítások): link

    
válasz adott Cactux 29.04.2015 23:11
forrás
106

Az Ubuntu Make program segítségével letöltheti és telepítheti a Visual Studio kódját:

sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
sudo apt-get update
sudo apt-get install ubuntu-make

Akkor telepítse a Visual Studio kódot:

umake ide visual-studio-code

Ezután kattintson a Visual Studio ikonra, amely automatikusan elhelyezi az indítóban.

Az eltávolításhoz törölje a telepítési mappát, és kattintson az egér jobb oldali gombjával az ikonra. A telepítési mappa alapértelmezése:~/tools/web/visual-studio-code

Referenciák

válasz adott Jorge Castro 30.04.2015 13:59
forrás
60

A Visual Studio Code engedélyezett hivatalos Linux-adattárakat a 2017 februárban (v1.10)

sudo add-apt-repository -y "deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main"
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EB3E94ADBE1229CF
sudo apt update
sudo apt -y install code

A szokásos módon frissítheti / elkülönítheti

sudo apt -y upgrade
sudo apt -y dist-upgrade
    
válasz adott zurfyx 22.03.2017 20:43
forrás
35

Most van egy .deb csomag az Ubuntu és a Debian számára az rpm / zip mellett. Ez elérhető itt , és a szokásos módon telepíthető:

sudo dpkg -i vscode-amd64.deb

A Xenial-on jól működik. Talán valaki létrehoz egy PPA-t a frissítések egyszerűsítéséhez. Vagy a hivatalos adattár részévé válik.

Frissítés 03/17: Az 1.10 verzió óta (2017 február) van a beépített támogatást a hivatalos Linux-adattárakhoz. A VS kód automatikusan frissíthet Linuxon, de manuálisan kell telepíteni egyszer.

    
válasz adott JeffRSon 04.05.2016 14:07
forrás
14

Mivel egy.deb fájlt adnak meg, most azt javaslom, hogy használja a következő megközelítést.

A következőképpen jártam el. Terminál használatával:

  1. Hozzon létre egy könyvtárat a fájlokhoz, és módosítsa ezt a könyvtárat:

    mkdir msvs && cd msvs
    

A könyvtár neve tetszőleges.

  1. Csomagolja ki a zip fájlt az új mappában:

    unzip ../Downloads/VSCode-linux-x64.zip
    
  2. Futtassa az ideet a

    segítségével
    ./VSCode-linux-x64/code &
    

Ezenkívül létrehozhat egy asztali kapcsolatot is, hogy elindíthatja azt közvetlenül az asztalról, vagy kattintson duplán a nautilusban.

menübejegyzés létrehozása:

  1. A terminálon hozzon létre egy fájlt

    sudo gedit /usr/share/applications/MSVS.desktop
    

és másolja be és illessze be a következőt:

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Exec=/opt/msvs/code
Name=MSVS
Icon=/opt/msvs/flurry_ios_visual_studio_2012_replacement_icon_by_flakshack-d5nnelp.png
Categories=Development

Saját esetemben a végrehajtható fájl a/opt/msvs -ban található.

sudo cp -R ~/Downloads/VSCode-linux-x64 /opt/msvs

Én is letöltöttem egy MS-ikont az alkalmazáshoz

wget http://fc06.deviantart.net/fs70/i/2012/344/9/1/flurry_ios_visual_studio_2012_replacement_icon_by_flakshack-d5nnelp.png

és áthelyezte a következőre:/opt/msvs:

sudo mv flurry*png /opt/msvs
    
válasz adott Harris 29.04.2015 23:11
forrás
9

Telepítse a snapot.

sudo apt install snapd-xdg-open
sudo snap install vscode --classic
    
válasz adott Martin Wimpress 20.05.2017 13:55
forrás
4

A Visual Studio kódot önmagában nem kell telepíteni. Ehelyett felszabadíthatja az archívumot bárhová is, majd futtassa a programot úgy, hogy duplán kattint acode nevű fájlra (amely a fő végrehajtható).

Itt egy GUI-orientált eljárás:

  1. Menjen a Visual Studio Code webhelyre, és kattintson a Kód letöltése Linuxra . (Valószínűleg át kell tekintenie a licencfeltételeket és a adatvédelmi irányelvek .)

  2. Hozzon létre egy új mappát, ahová a Visual Studio kódot meg kívánja menni. Ez a legjobb megoldás a saját mappáján belül (ha más felhasználók használni szeretnék a Visual Studio kódot, kiválaszthatók a számukra elválasztva), akkor minden módosítás vagy konfiguráció módosítása per-felhasználó lesz.

    Ez a célmappa üresnek kell lennie, mivel a.zip archívum a letöltéshez nem rendelkezik mindent a felső szintű mappában. Ha például a~/opt -ban telepítette a saját felhasználójára telepített szoftvert, létre lehet hozni egy új mappát benne:VSCode-linux-x64.

  3. Kattintson a jobb egérgombbal a letöltött .zip fájlra, és kattintson az Kivonat ... lehetőségre, majd válassza ki a létrehozott mappát.

    Ha tetszik, vagy ha a fájlböngésző nem jelenít meg Kivonat ... opciót, helyettesítheti a .zip fájlt a célmappába, kattintson jobb gombbal az ikonra, és kattintson a Kivonat itt elemre.

  4. A Visual Studio kód futtatásához kattintson duplán acode futtatható fájlra, amely az egyik kibontott fájl.

    A Visual Studio Code jelenleg "előnézeti" szoftver, ami azt jelenti, hogy még fejlesztés alatt áll és még nem teljesen stabil. Ezért érdemes elindítani egy terminálról, hogy hasznos hibákat és figyelmeztetéseket láthasson. Ehhez nyissa meg a Terminál ablakot ( Ctrl + Alt + T ),cd ./code.

válasz adott Eliah Kagan 29.04.2015 23:25
forrás
1
  • Töltse le a Powerbase telepítőszkriptet a Visual Studio kódra

  • Legyél root

    sudo -i
    
  • Változás a letöltési könyvtárba (valószínűleg~/Downloads/)

    cd /home/*yourusername*/Downloads/
    
  • Futtassa a telepítő szkriptet. Ha nincs hiba, akkor csak kilép ...

    sh ./vscodeinstaller.sh
    

Ez az. Semmi különös ebben, és minden Linux disztribúcióban működnie kell. Nyisd meg az indítópultot és kezdd el begépelni a Visual Studio kódot.

    
válasz adott Ilyes Boudjelthia 30.04.2015 17:24
forrás
1
  • Telepítse agdebi csomag telepítőt
  • Töltse le a.deb VSCode csomagot a itt
  • A letöltött csomagot agdebi
válasz adott Saikat 12.08.2017 05:29
forrás
1

A VS-kód telepítése Ubuntu-ra

curl https://packages.microsoft.com/keys/microsoft.asc | gpg --dearmor > microsoft.gpg
sudo mv microsoft.gpg /etc/apt/trusted.gpg.d/microsoft.gpg
sudo sh -c 'echo "deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main" > /etc/apt/sources.list.d/vscode.list'

Ez letölti a gpg kulcsot, majd másolja és elkészíti az apt fájlokat. Ezután egyszerűen frissíthet és telepíthet vs code :

sudo apt-get update
sudo apt-get install code
  • A telepítési módszer előnye, hogy az apt-get update paranccsal egyszerűen frissítheti a vscode-ot. Rendben van, és több mint 2 éve használok vs code a vim plugin több mint 2 éve (c, c ++, python, md, latex, html, javascript ...) li>

BTW, a VS kód lesz az Ubuntu 18.04 (2018 április végéig) standard csomagja!

    
válasz adott abu_bua 08.04.2018 10:43
forrás
1

A Visual Studio Code hivatalos dokumentumaitól:

  1. Töltse le a .deb csomagot a oldalon .
  2. Futtassa a következő parancsot: sudo dpkg -i ~/path-to-file.deb
  3. Ha függőségi hibákat kap a dpkg csomaggal történő használata során, futtassa: sudo apt-get install -f

Megjegyzés: A .deb csomag telepítése automatikusan telepíti az apt tárat és az aláíró kulcsot, hogy engedélyezze az automatikus frissítést a rendszeres rendszermechanizmus segítségével.

    
válasz adott Jebin Philipose 16.04.2018 20:17
forrás
1

Új FLATPAK (flathub) adattárat telepíthet bármely linux-elosztó linkre

A FLATPAK automatikusan frissíti a telepített csomagokat.

    
válasz adott Jiří Doubravský 03.05.2018 13:42
forrás
0

Nem tudok megjegyzést fűzni a fenti helyes válaszhoz (februárban a PPA használatával), ezért további részleteket adok hozzá.

A Visual Code függ a libgtk2.0-0-tól, amely nem szerepel a metaadatokban való függőségként. Lehet, hogy ez a probléma akkor fordulhat elő, ha Ön, mint én, minimális virtualbox telepítést állít fel, csak azért, hogy hibás rendszerszintű problémákat szüntessen meg, ahol hackelnie kell és el kell dobnia azokat a csomagokat, amelyeket nem szeretne az Ön valós gépén.

A minimális gazdaállomásokon a fentiek mellett a következőkre van szükség a Visual Code futtatásához:

sudo apt install libgtk2.0-0
    
válasz adott user2427436 04.10.2017 12:21
forrás