Az újabb Nautilus verziók hagyományos keresési módja

128

Mostanáig a Nautilus "hagyományos" verzióját használtam: ez az Ubuntu 10.10-el. Most a 3.6.3-at használom, az Ubuntu 13.04-es verziójával együtt. (Valószínűleg minden friss verzió megegyezik a kérdésem hatókörével).

A kettő között a legfontosabb különbség a keresési-te-típusú viselkedés: a Nautilus klasszikus verzióiban, amikor beírt egy bemenetet, a legközelebbi betűkkel rendelkező fájl lesz a kiválasztott, a jogosult fájlok / mappák az aktuális könyvtárra korlátozódik.

Az új viselkedés szerint opcionálisan globális keresést végez.

Lehet-e beállítani a Nautilust az előző funkciók rendelkezésre bocsátására?

    
készlet vemv 29.03.2013 19:48
forrás

5 válasz

118

Ubuntu 17.10 és 18.04

Mivel a típus-előretekintés egy Ubuntu-specifikus javítás volt, a 17.10-ben bezárták a Unity-t. Az arch archívumban azonban van egy nautilus-typeahead nevű csomag. Valaki átvette, összeállította az Ubuntut, és elkészítette a PPA-t. Ezt a három parancs segítségével telepítheti:

sudo add-apt-repository ppa:lubomir-brindza/nautilus-typeahead
sudo apt dist-upgrade
nautilus -r

Van egy probléma a Launchpadon , hogy visszaküldi ezt a viselkedést a hivatalos Ubuntu-hoz.

Ubuntu 14.04-17.04

Mivel az Ubuntu 14.04 LTS kiadása a típus-előretekintés volt az alapértelmezett viselkedés a Nautilusban újra .

A dconf billentyűvel válthat a különböző keresési módok között:

  • engedélyezze a következőket:

    gsettings set org.gnome.nautilus.preferences enable-interactive-search true

  • tiltsa le a következőt: - a rekurzív keresés érdekében:

    gsettings set org.gnome.nautilus.preferences enable-interactive-search false

Ubuntu 13.04 és 13.10

Amennyire én tudom, az új Nautilus 3.6.x számos funkciót vág a 3.4-es és a régebbi verziókból. A Canonical úgy döntött, hogy a nautilus 3.4.2-et használja az Ubuntu 12.10-ben, mert ez még akkor is, ha a Nautilus 3.6 már kiadásra került. Nem hiszem, hogy a régi keresési viselkedés 3.6-ben lehetséges, de az, amit telepítettem, a A SolusOS javította a Nautilust (szintén működik az Ubuntu 13.04-hez ), amely tartalmazza a 3.4.2-ből (valójában Nautilus 3.4.2-ből) származó összes funkciót, miközben megőrzi a Nautilus 3.6 bőrt. Ezt a csomagot teszteltem, és jól működik az Ubuntu 12.10 és 13.04 verzióban.

Alternatív megoldásként telepítheted a Nemo File Explorer-t, amely a Nautilus 3.4 villája, mivel a Cinnamon dev csapata csalódott a Nautilus 3.6-mal, itt találja a telepítési utasításokat .

Az alapértelmezett fájlböngésző létrehozása egy kicsit trükkös, ez blogbejegyzés az Ubuntu 12.10-ben dolgozott, de néhány felhasználó arról számolt be, hogy a módszer nem működik megfelelően.

Vannak alternatív módszerek. Lásd a következő kérdést:

válasz adott Fernando Domínguez 06.04.2013 16:06
forrás
15

Az Ubuntu Gnome 14.04-ben nyissa meg adconf-editor parancsot. Menjen a org > gnome > nautilus > beállításokra .

Jelölje be az engedélyezés-interaktív keresés melletti jelölőnégyzetet. Restart nautilus

    
válasz adott user3605908 26.05.2014 02:02
forrás
12

Ubuntu 18.04

Nos, ez a probléma elég motivált nekem, hogy végre megnézzem az Ubuntu PPA benyújtási folyamatát; itt megtalálhatja a Nautilus (bionikus) alkalmazást az alábbi Arch közösség patch-el: link és futtatásával telepítheti:

sudo add-apt-repository ppa:lubomir-brindza/nautilus-typeahead
sudo apt dist-upgrade
nautilus -r
    
válasz adott Halka 03.05.2018 19:19
forrás
2

A Nautilus 3.26-os verziója (a jelenlegi verzió az Ubuntu 17.10-ben). Ami a saját verzióját a forrástól építette, egy patch segítségével, amelyet a lenyűgöző archlinux közösség biztosít. Szerencsére az Ubuntu nagyszerû rendszere nagyon könnyû. Itt van a lépések. Feltételezem, hogy a ~ / bld-nautilus-typeahead-ban dolgozol. Indítsa el a konzolt, és tegye a következőket:

# install some necessary tools
sudo apt-get install git

# Create your work directory and go there
mkdir bld-nautilus-typeahead ; cd bld-nautilus-typeahead

# Clone the repository holding the needed patch: 
git clone https://aur.archlinux.org/nautilus-typeahead.git

# Make sure the source repositories for the main archives are available:
sudo nano /etc/apt/sources.list

# If the deb-src line for the main repository (usually around line 6) is commented out (starts with a #), un-comment it (remove the #) and save the file
sudo apt-get update

# Install the build dependencies
sudo apt-get build-dep nautilus

# Retrieve the sources for Nautilus
apt-get source nautilus

# Source should now be in the 'nautilus-3.26.0/' folder. Go there
cd nautilus-3.26.0/

# and Apply the patch from arch-linux
patch -p0 < ../nautilus-typeahead/nautilus-restore-typeahead.patch

# Build the package from source
dpkg-buildpackage -rfakeroot -uc -b

# This will take a little time. If everything goes well, the related packages will end up in the parent directory. Go there
cd ..

# and install the required packages
sudo dpkg -i nautilus_3.26.0-0ubuntu1_amd64.deb nautilus-data_3.26.0-0ubuntu1_all.deb

Új Nautilus indítása. Írjon be néhány betűt. Tapasztalja meg az öröm érzését, amelyet a kívánt fájl kiválasztásakor kiválaszt.

    
válasz adott Daniel Reus 03.02.2018 01:48
forrás
0

A Nautilus 3.25-ös vagy annál nagyobb válasz hiányzik & nem jön vissza, hacsak valaki teljesen újraírja az Ubuntu patch & esélye, hogy rendkívül vékony -hoz sem.

Ez nem valami, amit a nautilusban lehet beállítani.

    
válasz adott doug 17.09.2017 19:56
forrás