Wifi nem működik a felfüggesztés után 16.04 frissítés után

134

A "nem működik a felfüggesztés után" ez a változata a 16.04-es frissítés után jött. Úgy tűnik, hogy a frissítés Wicd appletet tartalmaz (hozzáadva a Metacity Classic Gnome tálcához a rendszeres hálózati ikon mellett), de úgy tűnik, hogy nem működik egy felfüggesztés után. Asudo service network-manager restart ismétlik ezt a problémát. Teljes újraindításra van szükség, hogy újra elinduljon a Wifi. Minden ötlet, miért?

    
készlet 147pm 23.04.2016 13:42
forrás

10 válasz

161

16.04 rendszeren fut. Próbálja ki a következőket:

sudo systemctl restart network-manager.service

Ha ez működik, létrehozhat egy szkriptet, amely automatizálhatja.

Nyisson meg egy terminált, és írja be a következőt:

sudo nano /etc/systemd/system/wifi-resume.service Most illessze be a szkriptet jobb kattintással. Lépjen ki a CTRL + X gombbal, majd nyomja meg az Y gombot a mentéshez. Most aktiválni:sudo systemctl enable wifi-resume.service

Script:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Remélem ez segít. A laptopom működik.

    
válasz adott Joakim Koed 23.04.2016 15:17
forrás
8

@ 147pm Mindig ezt dolgoztátok?

Úgy találtam, hogy nagyon hasonló probléma voltam, bár a Kubuntu 16.10-en (KDE-alapú, nem Gnome) és egy HP ProBook laptopon vagyok. És, ellentétben magával, nem az én Wifi, ami meghalt a felfüggesztés / ébresztés után, de az ethernet portom. Mégis, kíváncsi vagyok, vannak-e kapcsolatban.

Azt is látom, hogy nincs probléma a KDE alatt. De szeretném tudni, hogy az alábbi megoldás segít-e a Gnome alatt, mivel a megoldás nem az ablakkezelő, az asztali környezet vagy az appleteken alapul.

Először is, csak annak megerősítéséhez, hogy újraindította a hálózati menedzser szolgáltatást ..

$ sudo systemctl restart network-manager.service

nem működött értem.

Mindazonáltal találtam választ, ami a buzhidao kérdése és információi alapján készült, nem tud csatlakozni az internethez a felfüggesztés után és a GAD3R megjegyzésében.

Az információim használatával megállapítottam, hogy először azt vizsgáltam, hogy mely ethernet hardver és illesztőprogram / modul fut, majd eltávolítom és újratelepítem azt a modulot, nekem működött (bár nem buzhidao-ra):

WiFi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

A második ezek közül (ethernet) használtam, és azt találtam:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

így újratelepítettem az 'r8169' illesztőprogramot:

$ sudo rmmod r8169 && sudo modprobe r8169

és voila! Ez működött. Az ethernet portom / kapcsolatom életre kelt (felfüggesztés / ébresztés után), anélkül, hogy újraindítanod kellene.

(Nekem még nem volt Realtek wifi eszköz, hanem egy Qualcomm Atheros (mod: ath9k), ami talán megmagyarázza, hogy a wifi miért folytatta a munkámat a wake-from-suspend után.)

Amint azt a másik bejegyzésemről szóló megjegyzésemből kiderül, azon tűnődtem, hogy a probléma a közös elem a Buzhidao és én: Realtek Semiconductor készülékek között. Bár különböző modulokat használnak, megoszthatnak közös kódot? Vagy más módon kezelheti az új kernel-kódot valamilyen módon?

Önnek van egy Realtek alapú wifi eszköze? (az lspci használatával)? Szerencsére van a modul újratelepítése (rmmod / modprobe fent)?

Mindenesetre csak egy lövés a sötétben. Ha megtalálta a lehetséges választ magának, kérjük, értesítsen minket! Thx.

    
válasz adott androclus 16.03.2017 23:40
forrás
6

Ahhoz, hogy automatikusan újraindíthassa a NetworkManager-et, miután folytatta a környezetet asudo hozzáférés nélkül, írjon szkriptet a/etc/pm/sleep.d -ban (bármely név), állítsa be a végrehajtható bitet achmod +x -on keresztül, és helyezze be a következő tartalmat:

case "" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Számomra aservice vonal működött, de asystemctl jobban működik az Ön számára.

Forrás: link .

    
válasz adott krlmlr 05.11.2016 08:50
forrás
2

Számomra véletlenszerűnek tűnik, de néha a wifi csak akkor kapcsolódik le, ha csatlakozom, vagy nem mutat hálózatokat, ha nem. Néha úgy tűnik, hogy a laptopomat alvó üzemmódba helyezi, de nem mindig.

Ezek egyes kombinációja rendszerint újraindítás nélkül megy újra:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • sudo service network-manager stop; sleep 5; sudo service network-manager start
    • Egyszerűen hívja arestart -ot itt soha nem működik számomra. Úgy tűnik, hogy megpróbálja elindítani, mielőtt befejezte a leállítását, ezért több szerencsét hagyok astop és astart között.
  • Kapcsolja ki a wifi szolgáltatást az UI-ban; várjon néhány másodpercet; kapcsolja vissza

Úgy tűnik, hogy ezek közül egyik sem működik következetesen, de a legvalószínűbbek szerint a sikerhez rendeltem.

    
válasz adott redbmk 20.12.2016 17:07
forrás
2

Munkafolyamat Ubuntu 16.04:

A szolgáltatás létrehozása:sudo nano /lib/systemd/system/wifi-resume.service

A szolgáltatás a következő programot hívja:
/etc/init.d/network-manager

Illessze be a kódot:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Akkor engedélyezze a szolgáltatást:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Ez létrehozza a szimbolikus linkeket az / etc / systemd / system jelzett [Install] könyvtáraiba, és aktiválja a szolgáltatást

Ezt követően ellenőrizheti az állapotot:systemctl status wifi-resume.service

    
válasz adott cryptoboy 23.01.2017 01:59
forrás
1

Ugyanaz a probléma a bluetooth-val kapcsolatban: Miután felfüggesztette a bluetooth egeret, nem működött. Tehát a fenti megoldást a fentiből származtattam:

sudo nano /etc/systemd/system/bluetooth-resume.service

engedélyezte az új szolgáltatást

sudo systemctl enable bluetooth-resume.service

és szerkesztette a szolgáltatást

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Én is megpróbáltam szerkeszteni ...

sudo nano /etc/bluetooth/main.conf

és megváltozott

AutoEnable=true

De ez NEM működött a "folytatódó probléma" miatt, és semmilyen módon nem volt új bluetooth eszközökre!

    
válasz adott apos 31.08.2016 13:11
forrás
1

Ugyanaz a probléma voltam a Dell Inspiron 15R laptopomon, az Ubuntu 16.04-tel. Számomra a második válaszra jelentett forgatókönyv működött.

Miután telepítette a szkriptet, megpróbáltam felfüggeszteni a parancsot a jobb felső menüben, és még lezártam az ajkát, megoldva a problémát.

Azt kell mondanom, hogy a probléma váltakozó viselkedése (vagyis néha a script telepítése előtt működött).

    
válasz adott Alessandro D'lncal 18.01.2017 15:58
forrás
0

Számomra a megoldás futtatása

nmcli nm sleep false

egy terminálon

    
válasz adott tigerjack89 08.04.2017 13:01
forrás
0

Miután felfüggesztettem ugyanazt a problémát, visszatérve az otthoni WiFi-hoz. Megpróbálta a különböző egyéb javasolt válaszokat, amelyek alkalmanként működni fognak, de nem mindig.

Végül a következő javítás lehetővé tette a wifi rendszeres csatlakozását:

1) Szerkesztse ezt a fájlt:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Ezt hozzáadásával:

[device]
wifi.scan-rand-mac-address=no
    
válasz adott Ray Vega 28.03.2018 08:09
forrás
0

Most valószínűleg egyszerű

sudo apt update
sudo apt upgrade

működnie kell.

Az én esetemben a frissített csomagok közöttbcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) volt, és a frissítés után a wifi újra működik.

    
válasz adott Daniel 05.08.2018 07:08
forrás