Hogyan tilthatom le a vendégeket?

182

Hogyan tilthatom le a guest session-et Ubuntu 11.10 vagy újabb verziójában? Nem akarom, hogy az emberek használhassák a számítógépet a bejelentkezés nélküli jelszó használata nélkül!

    
készlet Jeremy Bicha 22.09.2011 17:45
forrás

12 válasz

118

Frissítve: 2016-Aug

Ubuntu 16.04 LTS (15.10 vagy újabb)

Alkalmazott: LightDM Ubuntu Wiki - Konfiguráció

  • A rendszer által megadott konfigurációs fájlok a (z)/usr/share/lightdm/ -ban nem szánták , hogy a felhasználók szerkeszthetők legyenek. Ehelyett a felhasználóknak:/etc/lightdm/
  • A LightDM (Ubuntu 15.10 vagy újabb verziója) újabb verziói[Seat:*] helyett[SeatDefaults]

Csak futtassa ezt (egyszer) a terminálon:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

A visszavonás (a vendég beállításának visszaállítása) eltávolítja a létrehozott fájlt :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Ubuntu 14.04 LTS (15.04-ig)

Alkalmazott: Ubuntu Fórumok - lightdm config fájlok helyét 14.04-ben

Csak futtassa ezt (egyszer) a terminálon:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Nem fog többé "Vendég" bejelentkezési opcióként, a következő bejelentkezéskor.

A visszavonás (a vendég beállításának visszaállítása) eltávolítja a létrehozott fájlt :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Ubuntu 12.04 LTS (13.10-ig)

A legegyszerűbb módszer

Csak futtassa ezt (egyszer) a terminálon:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Nem fog többé "Vendég" bejelentkezési opcióként, a következő bejelentkezéskor.

  • Ez egyszerűen hozzáfűzi aallow-guest=false -ot/etc/lightdm/lightdm.conf -hoz.

  • Ha 11.10 -ről dolgozik, akkor ezeket LightDM is használja.

Visszavonás (a vendég opció visszaállítása):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
válasz adott david6 28.07.2012 01:38
forrás
115
  

Csak akkor használja ezt a módszert, ha Ubuntu Desktopot használ. Ha olyan ízeket használ, mint az Xubuntu vagy a Lubuntu, akkor ezt a választ helyett.

Ha az alapértelmezett LightDM-et használja, akkor módosítsa a/etc/lightdm/lightdm.conf -ot úgy, hogy így néz ki:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Ha GDM-et használ (amely az előző Ubuntu kiadásokban alapértelmezett volt), távolítsa el a gdm-guest session

Az Ubuntu 13.10 és a 14.10 esetében a fájl átkerült a következőre:/etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Ubuntu 14.10 vagy magasabb verzió esetén a fájl átkerült /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
válasz adott Jeremy Bicha 22.09.2011 17:48
forrás
24

Írja be ezt a terminálba

gksu gedit /etc/lightdm/lightdm.conf

A következőket látja:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Add hozzáallow-guest=false -ot a végéhez, így a végeredménynek néznie kell:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Mentse el a dokumentumot, és lépjen ki a szövegszerkesztőből.

Vissza a Terminálra, indítsa újra a kijelzőkezelőt. (Ezzel befejeződik a grafikus bejelentkezési munkamenet, és azonnal lemond az összes benne futó programról, ezért győződjön meg róla, hogy a munkája - mint minden nyitott dokumentum - először mentésre kerül!)

sudo restart lightdm

A grafikus bejelentkezési munkamenet befejezése után visszakerül a bejelentkezési képernyőre, ahol észre fogod venni, hogy a vendégmegállapodás le van tiltva.

Ez az - a vendégfiók már nem használható.

    
válasz adott sarveshlad 25.10.2011 03:08
forrás
17

Ezt az Ubuntu Tweak használatával teheti meg.

A telepítéshez használja ezeket a parancsokat:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

A telepítés után keresse fel a Tweaks → Bejelentkezésbeállítások elemet, és kapcsolja ki a "Vendégfiókot".

    
válasz adott Eliran Malka 21.10.2012 19:54
forrás
11

Csak fuss

gksudo gedit /etc/lightdm/lightdm.conf

Adja hozzá a következő sort

allow-guest=false

Ezután (ez azonnal bejelentkezik, és kilép a grafikus munkamenetben futó programokból, így először mentse el a munkáját):

sudo restart lightdm
    
válasz adott LnxSlck 27.07.2012 18:42
forrás
4

Hogyan tilthatja le ezt a lehetőséget a jövőben

Ugyanazt a problémát futtattam az új megbízható / 14.04 telepítésemre. Meglepetésemre sem találtam alightdm.conf.d mappát belül:/etc/lightdm/ csakusers.conf.

Investigation

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, ott vagy. Mi van ott?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Oké, mi van ott?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Következtetés

A INI formátumhoz hasonló konfigurációs fájlokat találunk a50-${some-descriptive-name}.conf névadási sémáját követve, és konfiguráljuk a kulcsokat a[SeatDefaults] részhez.

Nem fogunk szerkeszteni ezeket a fájlokat , mivel ezeket a csomagkezelőnek kell kezelnie, de most hogyan kell hozzáadnunk és kezelnünk egyedi konfigurációs bitek </etc -ban.

Solution

A fentiek alapján a lightdm a kijelzőkezelő, és a konfigurációs fájlok a fentiekhez hasonlóan. A következő megoldásnak működnie kell:

  1. A hiányzó könyvtárak létrehozása:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Egyéni konfigurációs fájl hozzáadása futtatásával:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    és illessze be a következő sorokat:

    [SeatDefaults]
    allow-guest=false
    

    Ezután mentse ( Ctrl + O ) és bezárja ( Ctrl + X

  3. Most lépjen ki egy virtuális terminálra ( Ctrl + Alt + F1 ), majd futtassa:

    $ sudo service lightdm restart
    

    A vendéges munkamenet opciót most el kell hagyni. Ha valami nem működik rendesen, akkor tudni fogja, hogy az alapértelmezett konfiguráció tárolódott-e, és nem változtatta meg.

További olvasás

válasz adott LiveWireBT 16.03.2014 03:32
forrás
3

Ubuntu 13.10 hozzáadása

allow-guest=false

a/etc/lightdm/lightdm.conf.d/10-ubuntu.conf fájlhoz.

    
válasz adott uahummer 20.10.2013 15:27
forrás
3

13.04 és újabb

  1. Végezze el ezt a parancsot egy terminálon

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Indítsa újra a gépet, vagy indítsa újra alightdm parancsot a következő paranccsal: (ez azonnal el fog jelentkezni, mentse az adatokat)

    sudo restart lightdm
    

Úgy tűnik, 13.10-ben működik (nem tesztelhetem magam, de van egy megjegyzésem itt ).

13.04-et használok, és mindez ehhez aallow-guest=false -hoz/etc/lightdm/lightdm.conf -hoz tartozik, de 13.10-ben más lesz.

Eredetileg david6 innen innen: link

    
válasz adott kiri 21.10.2013 09:33
forrás
2

Telepítse az ubuntu-tweak-et, lépjen be a csípés fülre, kapcsolja ki a vendéggombot és indítsa újra. Ez az!

Lehet, hogy könnyebb lesz megtalálni a terminált, de abban az esetben, ha fel kell hívni a vendégfiókot, újra meg kell látogatnia ezt az oldalt, és meg kell néznie az utasításokat (vagy inkább visszavonja). Ez a GUI előnye ... könnyen emlékszik rá.

    
válasz adott tadatma 27.09.2012 19:33
forrás
2

Változtassaallow-guest=true -ra a'false' -ra a/etc/lightdm/lightdm.conf -ben

Ezután újraindíthatja vagy újraindíthatja a szolgáltatást a terminálon:

sudo restart lightdm

Abban az esetben, halightdm -ot használsz, ami standard 11.10-kor.

    
válasz adott filescraps 21.10.2011 12:42
forrás
0

Ugyanez a helyzet, a/etc/lightdm/lightdm.conf fájl nem létezik az UBUNTU 13.10-ben.

Megpróbálom létrehozni a/etc/lightdm/lightdm.conf fájlt ezzel a sorralallow-guest=false és CRASH, a rendszer nem indul el megfelelően, csak a konzol módban ...

Megpróbálom szerkeszteni a/etc/lightdm/lightdm.conf.d/10-ubuntu.conf fájlt, és jól működik.

A fájl szerkesztése

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

Adja meg a szükséges sorokat

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

És az utolsó, indítsa újra a rendszert

sudo reboot

Úgy gondolom, ez jól működik, ha csak a ligthgdm

újraindul
sudo service lightdm restart
    
válasz adott Foncu 23.10.2013 16:05
forrás
0

Terminál megnyitása

gksudo gedit /etc/lightdm/lightdm.conf

Adja hozzá a következő sort

allow-guest=false

A fájl mentése és kilépés.

    
válasz adott scouser73 21.10.2013 09:29
forrás