Hogyan deaktiválhatom a Bluetooth-ot a rendszer indításakor?

279

Hogyan tudom deaktiválni a Bluetooth-ot a rendszer indításakor?

    
készlet Floqqi 16.10.2011 23:02
forrás

28 válasz

190

18.04+ felhasználók, akiknek természetesen nincs /etc/rc.local, létre kell hozniuk és végrehajthatóknak kell lenniük. A dolgok kicsit könnyebbé tételéhez egyszerűen beillesztheti a következő parancsot egy terminálba:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Futtassa asudoedit /etc/rc.local -ot, és ezt hozzáadja aexit 0:

sorhoz
rfkill block bluetooth

Továbbra is képesnek kell lennie arra, hogy engedélyezze a Bluetooth-ot a felső sávsapleten keresztül.

Ez a a a legtöbb rendszeren működik, de úgy tűnik, hogy néhány hiba lurking a kernel ACPI Thinkpads-hez. Ha ThinkPad-on vagy, használd a következőt:/etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Vagy nézd meg az ibm-acpi - IBM ThinkPad ACPI Extrák illesztőprogram - egyes jelentések szerint az ibm-acpi tartalmaz bluetooth vezérlést (többek között szép dolgok). De nem rendelkezem a hardverrel, ezért nem tudom igazolni ezeket a követeléseket. Sok szerencsét.

    
válasz adott Oli 18.08.2010 11:00
forrás
73

Találtam egy módszert egy tiszta "megoldási" itt ( archív link az utókor számára)

Valójában a/etc/bluetooth/main.conf változása elég volt nekem.

A cikkből:

A bejegyzés keresése:

InitiallyPowered = true

és módosítsa az értéket:

InitiallyPowered = false

Elég volt számomra, bár a cikk olyan más lépéseket ír le, amelyek lehetnek vagy nem feltétlenül szükségesek.

Az Ubuntu 17.10 és Ubuntu 18.04 InitiallyPowered helyett aAutoEnable

    
válasz adott Stepbaer 25.06.2012 20:00
forrás
23

A bluetooth illesztőprogram indításkor történő betöltésének kikapcsolása:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

add:

blacklist btusb

A későbbi bekapcsolás csak:

sudo modprobe btusb
    
válasz adott maco 18.08.2010 18:59
forrás
16

1. lépés: Menjen a terminálba, és írja be a következő parancsot a/etc/rc.local fájl szerkesztéséhez:

gksudo gedit /etc/rc.local

2. lépés: Adja hozzá a következő sort aexit 0 sor előtt:

rfkill block bluetooth
    
válasz adott Varun 04.05.2012 22:44
forrás
12

Az ubuntu 16.04-től kezdve a systemd kezdi az indítási szolgáltatásokat, mint a bluetooth ... a terminál aktuális állapotkérdésének megtekintéséhez

sudo systemctl status bluetooth.service 

a bluetooth deaktiválásakor indításkor adja ezt

sudo systemctl disable bluetooth.service

majd a következő újraindításkor a bluetooth nem lesz aktív ... a bluetooth probléma engedélyezéséhez

sudo systemctl enable bluetooth.service
    
válasz adott Scott Stensland 01.08.2017 17:08
forrás
7

Írja be az alábbiakat egy terminálba:

sudo gedit /etc/modprobe.d/blacklist.conf

A fájl alján adja hozzá a sort:

blacklist bluetooth

A fájl mentése és újraindítása - A Bluetooth-ot most le kell tiltani.

    
válasz adott Nathan Osman 16.10.2011 23:25
forrás
7

A bootolással indított szolgáltatásokat BUM segítségével módosíthatja.

Telepítse:sudo apt-get install bum

Futtatás:sudo bum

Törölje a jelölőnégyzetet, és kattintson a Alkalmaz gombra.

    
válasz adott desgua 05.05.2012 02:09
forrás
5

Úgy gondolom, hogy a legjobb módja annak, hogy letiltja a szolgáltatást az első lépések megkezdésétől. Van egy általános módszer a szolgáltatások kikapcsolására, amely tökéletesen működik:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Ez működik az Ubuntu 13.10-hez és valószínűleg a korábbi verziókhoz is.

    
válasz adott Felipe 18.01.2014 10:49
forrás
5

Hozzáadom

"/etc/init.d/bluetooth stop"

be

"/etc/rc.local" 

a "kilépés 0" parancs elindítása a bluetooth-alapú indításhoz ki van kapcsolva.

    
válasz adott Saeed Zarinfam 23.08.2012 15:00
forrás
5

1. blokkolja a bluetooth-t rc.local

-ben

A következő sor hozzáadása a fájl végén/etc/rc.local jobb a sor előttexit 0:

rfkill block bluetooth

Ez a trükk, de csak a régebbi Ubuntu verziókban upstart .

2. reenable rc.local a systemd-ben

Az Ubuntu 15.10-en systemd indításkezelőként a/etc/rc.local fájl nem használ alapértelmezés szerint, ezért hívja ezt a terminálon:

sudo systemctl edit --full rc-local

Mely megnyitja a szerkesztőt. A fájl végén adtam hozzá:

[Install]
WantedBy=multi-user.target

A változásokat

aktiválja
sudo systemctl reenable rc-local

Most a/etc/rc.local fájlt használja, ahogy ismered.

3. letiltja a blueman-applet indításkor

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Most a blueman-applet látható, és letilthatja az indítóprogramokból

4. Indítsa újra a funkciót

    
válasz adott rubo77 10.11.2015 13:29
forrás
4

Aupdate-rc.d beállításait szerkesztheti. Valami hasonlóat használtam:

sudo update-rc.d bluetooth remove

A Debian Wheezy-ben. Tekintse meg aman update-rc.d -ot további információért a használatához.

    
válasz adott Keith Smiley 13.02.2013 16:50
forrás
2

Lehet, hogy kikapcsolhatja az indítási alkalmazásokban. De ezek az alkalmazások alapértelmezés szerint el vannak rejtve. Nyissa meg a rejtett indítási alkalmazást 12.04-ben: nyissa meg a terminált, és futtassa ezt a két parancsot:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Most törölheti a bluetooth-t. (Ne távolítsa el!)

    
válasz adott schiemanski 05.05.2012 10:50
forrás
2

Nem. Ez nem mindig az indítási applcations listában található. Úgy gondolom, hogy a legjobb megoldás az rfkill parancs rc.local parancsfájlban történő hozzáadása vagy aInitiallyPowered paraméter beállítása a/etc/bluetooth/main.conf -ban.

    
válasz adott Robert 05.05.2012 02:06
forrás
2

1) Telepítse a smbios-utils csomagot, és adjon hozzá indítási alkalmazásokhoz a következőhöz:

sudo smbios-wireless-ctl --bt 0

2) A terminál típusában:

sudo visudo

és adja hozzá a/etc/sudoers open line fájl megnyitásához:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) A Bluetooth bekapcsolása a munkamenet alatt futtatható a terminálon:

sudo smbios-wireless-ctl --bt 1

Ez nekem működik a Dell D630-on Ubuntu 13.10-el

    
válasz adott victor 15.03.2014 16:58
forrás
2

Az Ubuntu 16.04-en egyszerűen letiltottam a szolgáltatást a systemctl használatával.

Ehhez nyisson meg egy terminál ablakot, és írja be a következőt:

sudo systemctl disable bluetooth

Azonnal indíthatja újra a számítógépet, hiszen a bluetooth letiltásra kerül az indítás után, vagy ha nem akarja újraindítani a bluetooth-ot, és azonnal le akarja állítani a következőket:

sudo service bluetooth stop

    
válasz adott Ken 22.08.2017 05:57
forrás
2

Lehetőségünk van a Bluetooth indítás automatikus letiltására:

sudo gedit /etc/bluetooth/main.conf

(gedit az én kedvenc szerkesztőm, ezt helyettesítheti axed -kal vagy bármi más, ami telepítve van a rendszereden.)

A fájl alján van ez a sor:

#AutoEnable=false

Vegye fel a következő megjegyzést:

AutoEnable=false
    
válasz adott Shayan 20.02.2018 15:47
forrás
1

A Sputnik kernelt használtam, amely ezt a Dell Inspiron 14R N4110 készülékre rögzítette.

    
válasz adott Alex Wiedermann 25.09.2012 01:53
forrás
1

Szerintem szerkeszteni kell

/etc/default/bluetooth

és állítsa be

BLUETOOTH_ENABLED=0

a bluetooth szolgáltatás letiltása a rendszerindításkor

    
válasz adott Fabio 06.03.2014 21:17
forrás
1

Azok számára, akiknél a (z)rfkill block bluetooth (vagy bármely más)/etc/rc.local -on lévő sor beillesztése nem működik, próbálja meg ugyanazt a sort a~/.bashrc

Az én beállításomban (Ubuntu 14.04, Thinkpad W540) egyetlen opció sem működött a/etc/rc.local -ban, de az előbbi a bashrc-ben működött. Ne feledje, ez csak az aktuális felhasználó számára működik, nem globálisan minden felhasználó számára.

    
válasz adott Sam 19.10.2014 14:10
forrás
1

Az Ubuntu Studio 16.04 alkalmazásban letilthatja a Bluetooth-alkalmazást az indításkor:

  

Session and Startup > Alkalmazás Autostart > Bluetooth kisalkalmazás

Itt kattints a mezőre a letiltáshoz.

    
válasz adott ateymuri 26.08.2016 20:05
forrás
0

Hozzáadom

"/etc/init.d/bluetooth stop"

be

"/etc/rc.local" 

a "kilépés 0" parancs elindítása a bluetooth-alapú indításhoz ki van kapcsolva.

    
válasz adott Saeed Zarinfam 23.08.2012 15:05
forrás
0

Megoldás a notebookomhoz

"BIOS - USB konfiguráció - EHCI2: Letiltva"

Az EHCI1 az usb portokhoz (valójában a notebookomnak 2 usb 2.0 portja van)

    
válasz adott MSP 27.03.2014 19:46
forrás
0

Edit/etc/default/grub:

sudo nano /etc/default/grub

és módosítsa a következő sort:

GRUB_CMDLINE_LINUX=""

Ezt helyettesítheti:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Akkor frissítse a grubot és újraindul:

sudo update-grub
    
válasz adott mchid 21.09.2015 07:58
forrás
0

Ezzel le kell tiltani a bluetooth-ot a Debian alapú rendszerekről való indításhoz:

sudo chkconfig bluetooth off

vagy a RedHat alapú rendszereknél

systemctl disable bluetooth.service
    
válasz adott Stanislav 16.10.2017 22:18
forrás
0

Ha a felső panelen (blueman-applet) a Bluetooth-appletet használja, saját beállítása van, amely automatikusan bekapcsolja a Bluetooth-ot, ha más helyeken letiltotta (például / etc / bluetooth / main .conf vagy / etc / default / tlp).

A Bluetooth indításkor a parancssor használatával történő bekapcsolásának megakadályozása:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Vagy a grafikus felhasználói felületen keresztül:

  1. Kattintson a Bluetooth-applet > Plugins > PowerManager > Configuration
  2. Jelölje be az Automatikus bekapcsolás lehetőséget

A következő alkalommal, amikor újraindul, a Bluetooth-applet továbbra is látható lesz, de a Bluetooth kikapcsol. Kapcsolja be:

Kattintson a Bluetooth applet > A Bluetooth bekapcsolása

    
válasz adott bmaupin 27.07.2018 19:12
forrás
-1

Kényszerített módszert kellett használnod ahhoz, hogy a bluetoothd automatikusan leálljon bootoláskor. Átneveztem a végrehajtható fájlt, így nem találtam.

    
válasz adott bluesdiva2001 06.07.2012 03:02
forrás
-1

Ezt a Grafikus alkalmazást is használhatja, amely ezt a bluetooth-kezelőt is ellátja

    
válasz adott deFreitas 27.12.2014 14:26
forrás
-3

Le kell tiltani azt a Rendszerbeállítások indítási alkalmazások listájában.

Kattintson a fogaskerékre a menüsor jobb felső sarkában, majd válassza a Rendszerbeállítások elemet.

Kattintson az Alkalmazások indítása, majd görgessen lefelé, amíg meg nem találja a bluetooth beállítást, vegye ki a jelölést a dobozból, és mindent megtett.

    
válasz adott Mark Rooney 16.10.2011 23:13
forrás