Nem sikerült használni az IntelliJ IDEA billentyűparancsokat az Ubuntuban

118

Nagyon új vagyok az Ubuntu számára, és problémám van, hogy nem tudom, hogyan kell rögzíteni. Még próbáltam megkeresni az interneten a válaszokat, de talán nem ismerem a megfelelő feltételeket, hogy keressem.

A IntelliJ IDEA fejlesztési alkalmazással dolgozom. És nagyon jól használom a billentyűparancsokat, de amikor átmentem a Windows XP-ről az Ubuntu 13.10-re, néhány parancsikon már nem működik. Például:

  • Ctrl + Alt + (balra nyíl)
  • Alt + F8

Van-e ok arra, miért? és van-e valamilyen megoldás erre? Vagy talán valami, ami irányítaná a keresést

Köszönöm szépen előre.

    
készlet Rodrigo Sasaki 28.01.2014 13:01
forrás

10 válasz

188

Mint egy kis olvasás, azt tanította, hogy az Intellij IDEA egy billentyűcentrikus IDE. Ami azt jelenti, hogy egy alkalmazás működhet vele anélkül, hogy érintenie kellene az egeret. Szintén találom meg a billentyűzet beállításait.

Ubuntuhoz

Lásd hogyan változtathatja meg a billentyűparancsokat

Az alábbiakban felsoroljuk azokat a csípéseket, amelyeket az alapértelmezett rendszerkulcs-összerendelésekkel kell végrehajtani, hogy azok ne zavarják az IntelliJ IDEA műveleteket (zárójelben szerepelnek).

  
  • Letiltja az Árnyék ablak műveletet, amelyet Ctrl + Alt + S (Beállítások párbeszédpanel)
  •   
  • Változtassa meg vagy tiltsa le a Lock Screen műveletet Ctrl + Alt + L (Reformát kód)
  •   
  • A Launch terminál művelet módosítása vagy letiltása Ctrl + Alt + T (Surround with)
  •   
  • A Ctrl + Alt + nyílgomb (Navigáció)
  •   
  • Letiltja az Áthelyezés ablak műveletet, amely az Alt + F7 (Hasznosítás keresése)
  •   
  • Módosítsa vagy letiltsa a Alt + F8 (kiértékelési kifejezés)
  •   

Remélem ez segít!

Megjegyzés: Az Ubuntu hivatkozásokat mindig visszaállíthatja az alapértelmezett állapotba. Csak Hogyan visszaállíthatom az alapértelmezett billentyűparancsokat? , ha elveszett .

Forrás: - Intellij IDEA Keymap

    
válasz adott AzkerM 28.01.2014 13:39
forrás
28

Nekem is ez a probléma, de megoldásom más volt.

Nincs hack, vagy megváltoztatta a rendszeres billentyűparancsot

Az IntelliJ különböző keymapokkal rendelkezik, amelyek az operációs rendszertől függően megváltoztathatók.

Módosíthatja az IntelliJ Keymap szolgáltatást a beállításokból.

Csak menjen aSettings -> Keymap -ra, és válassza ki a kívánt billentyűparancsot a legördülő menüből. Az én esetemben az "Alapértelmezés a GNOME-hoz" választottam, mivel az Ubuntu Gnome 16.04-et használom.

    
válasz adott Francisco C. 25.06.2016 07:18
forrás
14

Ubuntu 18.04 LTS esetén ctrl + alt + balra (Intellij elképzelés parancsikonja)

  • telepítse a Dconf Editor alkalmazást az ubuntu szoftverben
  • indítsa el a Dconf Editor alkalmazást, folytassa / org / gnome / desktop / wm / billentyűkombinációk / átváltás a munkaterületre-balra

  • dupla kattintás

  • használja az alapértelmezett értéket (kattintson a Kikapcsolva) - > Egyéni érték (mint én vagy más)

  • használhatja az intellij-ötletben most

    
válasz adott think 06.05.2018 11:42
forrás
5

Készítettem ezt a szkriptet, amely letiltja az Ubuntu (15.10-ig tesztelt) és az IntelliJ (és valószínűleg több Jetbrains termék) közötti ütköző parancsikont. Letiltja őket az Ubuntuban.

Ezenkívül létrehoz egy biztonsági másolatot, így visszaállíthatja korábbi beállításait.

Ahhoz, hogy néhány parancsikon ne legyen letiltva, ossza meg őket aKEYS tömbben.

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Megkaphatja innen:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
válasz adott Jonas Gröger 16.12.2015 22:40
forrás
3

Lásd: itt az Ubuntu gyorsbillentyűk programozásának kikapcsolására, és csak akkor, ha bizonyos alkalmazások ablakai aktívak.

Pontosan használja ezeket az értékeket (feltételezve, hogy a JetBrains eszköztárat a szokásos telepítési útvonalával használja, másképp igazodik):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

A szkript futása közben az Ubuntu parancsikonok mindig működni fognak, kivéve ha IDEA et al. van fókusz.

Van egy gyűjtemény a JetBrains-specifikus parancsikonokról itt ; a bemenet értékeli.

    
válasz adott Raphael 22.12.2016 14:32
forrás
2

Csak hogy kicsit kibővítsd az AzkerM kiváló válaszát:

  
  • Letiltja az Áthelyezés ablak műveletet, amelyet Alt + F7      
        
    • a Beállítások - > Billentyűzet - > Gyorsbillentyűk - > Windows - > Mozgassa az ablakot
    •     
  •   
  • Változtassa meg vagy tiltsa le a Alt + F8 (a kifejezés kiértékelése) hozzárendelt Átméretezés ablak műveletet      
        
    • a Beállítások - > Billentyűzet - > Gyorsbillentyűk - > Windows - > Az ablak átméretezése
    •     
  •   
    
válasz adott WillC 24.02.2016 12:15
forrás
1

Ubuntu 16.04-et futtatom, és mi történt, amikor ezeket a kulcstényezőket használtam (ctrl-alt-bal / jobb), az ablakot átméreteztem, és a képernyö jobb vagy bal oldalára helyeztem. Megpróbáltam kikapcsolni ezeket a kulcskapcsolatokat: Beállítások / Billentyűzet / Navigáció, annak ellenére, hogy nincsenek engedélyezve munkaterületek. Még mindig nem akadályozta meg a viselkedést, amit láttam.

Szerencsére megnyitottam a Compiz-et, és megbotlottam az ablakkezelő / rács bővítményen, amely ezeket a gombokat feltérképezte, hogy az ablakokat rácspozícióba helyezze. Letiltottam ezt a plugint, és most az IntelliJ kulcs gyorsbillentyűi jól működnek a ctrl-alt-bal / jobb oldalon.

    
válasz adott Jason White 14.06.2016 00:08
forrás
1

Csak néhány gyors megoldás:
Ha van egy " Windows " billentyű a billentyűzeten, akkor csak hozzáadhatja a teljes parancsikombinációhoz - működnie kell. Például:

  • < Alt + Ctrl T (Surround vele)
  • < F8 (Értékelje a kifejezést Win
válasz adott guzoff 28.11.2017 21:53
forrás
0

Az Ubuntu 16.04-hez menjen a beállítások > Billentyűzet , és keresse meg az adott kombinációt, amely ellentétben áll a kívánt kattintással, és frissítse a kombinációt egy másikra.

    
válasz adott Cengkuru Michael 29.10.2017 10:22
forrás
0

A Xneur-t használom a rosszul írt szöveg más nyelvre váltásához. A rendszer langauge-jétCtrl + Shift követi: blokkolja az Intellij gyorsbillentyűket , mintCtrl + Shift + F (globális keresés) ésCtrl + Shift + C (megjegyzés). Tehát a bal műszakot figyelmen kívül hagyja.

  • Az egyik megoldás a nyelv megváltoztatása aCtrl_L + Shift_L és a használatával Ctrl_R + Shift_R az Intellij számára . De ez valami kellemetlenség.

  • A másik megoldás a Xneur (sudo ap-get install xneur) használata írja be újra a helytelen szöveget más nyelven. Letilthatja bármelyik rendszerű nyelvváltást, és rendelheti hozzá a xneur gyorsbillentyűkhöz (azonosCtrl+Shift). A Xneur hozzáadható az automatikus indítású alkalmazásokhoz.

válasz adott Zon 04.09.2018 07:28
forrás